Discussion:
-openssl-linked required package for Ubuntu 18.04
(too old to reply)
r***@logikalsolutions.com
2018-11-28 16:55:09 UTC
Permalink
All,

Qt 5.9.7

libssl-dev is installed on both 14.04 and 18.04. All additional
packages installed from same script. On 14.04 this configure works
perfectly.

./configure -prefix /home/developer/Qt-5.9.7 -c++std c++11 -qt-xcb
-opensource -confirm-license -proprietary-codecs -qt-webengine-icu
-qt-webp -qt-ffmpeg -qt-opus -qt-libjpeg -qt-libpng -fontconfig
-qt-pcre -qt-zlib -system-freetype -qt-harfbuzz -qt-xkbcommon-x11
-qt-assimp -nomake examples -openssl-linked


On 18.04 it complains about SSL dependency not being met.

What lib needs to be installed on 18.04 to make configure happy?

Thanks
--
Roland Hughes, President
Logikal Solutions
(630) 205-1593

http://www.theminimumyouneedtoknow.com
http://www.infiniteexposure.net
http://www.johnsmith-book.com
http://www.logikalblog.com
http://www.interestingauthors.com/blog
http://lesedi.us
Konstantin Tokarev
2018-11-28 17:31:41 UTC
Permalink
Post by r***@logikalsolutions.com
All,
Qt 5.9.7
libssl-dev is installed on both 14.04 and 18.04. All additional
packages installed from same script. On 14.04 this configure works
perfectly.
./configure -prefix /home/developer/Qt-5.9.7 -c++std c++11 -qt-xcb
-opensource -confirm-license -proprietary-codecs -qt-webengine-icu
-qt-webp -qt-ffmpeg -qt-opus -qt-libjpeg -qt-libpng -fontconfig
-qt-pcre -qt-zlib -system-freetype -qt-harfbuzz -qt-xkbcommon-x11
-qt-assimp -nomake examples -openssl-linked
On 18.04 it complains about SSL dependency not being met.
What lib needs to be installed on 18.04 to make configure happy?
libssl1.0.0

(despite of package name, it installs latest 1.0.2 revision instead of EOL 1.0.0)
Post by r***@logikalsolutions.com
Thanks
--
Roland Hughes, President
Logikal Solutions
(630) 205-1593
http://www.theminimumyouneedtoknow.com
http://www.infiniteexposure.net
http://www.johnsmith-book.com
http://www.logikalblog.com
http://www.interestingauthors.com/blog
http://lesedi.us
_______________________________________________
Interest mailing list
https://lists.qt-project.org/listinfo/interest
--
Regards,
Konstantin
r***@logikalsolutions.com
2018-11-28 18:03:00 UTC
Permalink
Thanks!

I had just conducted that experiment myself. Well, am conducting.
Configured fine and am building now. Just need to be sure the Deb will
build on 14 then install and run on 16 and 18. SSL not actually used
in this release, just don't want to have to yick with the build
machines once configured. Next release (when approved) should have
only internal changes.

Thanks again,
Roland
Post by Konstantin Tokarev
Post by r***@logikalsolutions.com
All,
Qt 5.9.7
libssl-dev is installed on both 14.04 and 18.04. All additional
packages installed from same script. On 14.04 this configure works
perfectly.
./configure -prefix /home/developer/Qt-5.9.7 -c++std c++11 -qt-xcb
-opensource -confirm-license -proprietary-codecs -qt-webengine-icu
-qt-webp -qt-ffmpeg -qt-opus -qt-libjpeg -qt-libpng -fontconfig
-qt-pcre -qt-zlib -system-freetype -qt-harfbuzz -qt-xkbcommon-x11
-qt-assimp -nomake examples -openssl-linked
On 18.04 it complains about SSL dependency not being met.
What lib needs to be installed on 18.04 to make configure happy?
libssl1.0.0
(despite of package name, it installs latest 1.0.2 revision instead of EOL 1.0.0)
Post by r***@logikalsolutions.com
Thanks
--
Roland Hughes, President
Logikal Solutions
(630) 205-1593
http://www.theminimumyouneedtoknow.com
http://www.infiniteexposure.net
http://www.johnsmith-book.com
http://www.logikalblog.com
http://www.interestingauthors.com/blog
http://lesedi.us
_______________________________________________
Interest mailing list
https://lists.qt-project.org/listinfo/interest
--
Regards,
Konstantin
--
Roland Hughes, President
Logikal Solutions
(630) 205-1593

http://www.theminimumyouneedtoknow.com
http://www.infiniteexposure.net
http://www.johnsmith-book.com
http://www.logikalblog.com
http://www.interestingauthors.com/blog
http://lesedi.us
Thiago Macieira
2018-11-28 19:18:06 UTC
Permalink
Post by r***@logikalsolutions.com
What lib needs to be installed on 18.04 to make configure happy?
Can you find the section of the config.log where it tried to find openssl and
failed? It will have an error message there.
--
Thiago Macieira - thiago.macieira (AT) intel.com
Software Architect - Intel Open Source Technology Center
Continue reading on narkive:
Loading...